Docker-in-Docker (DinD) capabilities of public runners deactivated. More info

Commit cc00149d authored by Nicolas M. Thiéry's avatar Nicolas M. Thiéry
Browse files

Install imagemagick by conda rather than apt

Hopefully, this will help R's magick package compile better against it.
parent 8868afeb
......@@ -8,7 +8,7 @@ USER root
# Also install ocaml and dependency rlwrap for L2 CS course by Kim Nguyen
RUN apt-get update && \
apt-get install -y --no-install-recommends \
openssh-client rsync unison less tree curl gdb imagemagick libmagick++-dev libopenjp2-7 \
openssh-client rsync unison less tree curl gdb libopenjp2-7 \
ocaml rlwrap dune js-of-ocaml libjs-of-ocaml \
net-tools traceroute iputils-ping \
time \
......
......@@ -27,6 +27,7 @@ dependencies:
# Some additional packages that don't have a specific repo yet
# Visualisation
- imagemagick # used e.g. by R package animation, and many more
- matplotlib
- cycler # missing matplotlib dependency: https://stackoverflow.com/questions/44419333/matplotlib-cant-find-cycler
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment