📣 An issue occured with the embedded container registry on October 25 2021, between 10:30 and 12:10 (UTC+2). Any persisting issues should be reported to CC-IN2P3 Support. 🐛

Commit ea1db58b authored by LE GAC Renaud's avatar LE GAC Renaud
Browse files

Replace configure_build.py by w2pcfg.py.

parent c60fc6df
# -*- coding: utf-8 -*-
"""Configure the build process for the plugin_event
"""
# ............................................................................
#
# JAVASCRIPT LIBRARY
# JavaScript source code and compile version
# paths are relative to the static directory
#
SENCHA_CLS = [
"plugin_event/src",
"plugin_dbui/src",
"plugin_extjs/packages/core/src",
"plugin_extjs/classic/classic/src",
"plugin_extjs/classic/classic/overrides"]
SENCHA_NS = "Ext,Dbui"
JSLIBDEBUG = "plugin_event/event-debug.js"
JSLIBMIN = "plugin_event/event-min.js"
# ...........................................................................
#
# DOCUMENTATION
# output directories for documentation
# paths are relative to the static directory
#
DOCS_DIR = "plugin_event/docs"
JSDOC = "plugin_event/docs/jsduck"
LATEXDOC = "plugin_event/docs/latex"
PDFDOC = "plugin_event/docs/pdf"
# ...........................................................................
#
# PLUGINS
# event
# paths are relative to the application directory
#
PLUGINS_FILES = {}
PLUGINS_FILES["default"] = [
"controllers/plugin_%s.py",
"models/plugin_%s.py",
"modules/plugin_%s",
"private/plugin_%s",
"static/plugin_%s",
"views/plugin_%s"]
PLUGINS_FILES["event"] = [
"controllers/plugin_event.py",
"modules/plugin_event",
"static/plugin_event",
"views/plugin_event"]
# ............................................................................
#
# REFERENCE FILES
#
CHANGELOG = "static/plugin_event/CHANGELOG"
VERSION = "static/plugin_event/VERSION"
"""Configure the build process for the plugin_event
"""
# ............................................................................
#
# CONSTANTS
#
# DOCKER_API_VERSION = "auto"
# DOCKER_IMG_JSDUCK = "poum/jsduck:5.3.4"
# DOCKER_IMG_PDFLATEX = "pdflatex:2019"
# DOCKER_IMG_SENCHACMD = "poum/senchacmd:6.6.0.13"
# DOCKER_IMG_SPHINX = "sphinx:2.2.1"
# ............................................................................
#
# PLUGINS
#
# PLUGINS_DIR = Path("~/mywap/w2pext/plugins").expanduser()
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment